Aux lighting

Super8mm

Premier Member
#1
I just picked up a 07GT and I am wondering about extra lighting.

It seem every one is going to LED but does anyone have experience with LED compared to HID?

There are all sorts of critters out there at night :eek:

TIA
 
#2
I just picked up a 07GT and I am wondering about extra lighting.

It seem every one is going to LED but does anyone have experience with LED compared to HID?

There are all sorts of critters out there at night :eek:

TIA
I got a pair of Clear Water Lights. The difference is between night and day.

Douglas
 

JD Darden

Premier Member
#5
I have a set of Clearwater Kristas and a set of Ericas on my GSA and a pair of Kristas on my GTL. I swear by them for riding at night. No problems spotting deer much further out than the stock lights and factory accessory lights. No experience with recent HID lights for comparison though. I point the right one slightly more to the right to see them further from the road. I saw one guy had one Erica and one Krista (one for distance and one wide) and will be trying that soon. I also run the Ericas with yellow covers during the day and seem to have less problems with cars seeing me.
 

Stephen!

Premier Member
IBA Member
#7
Stephen, what led h7 replacement bulbs did you eventually settle on. I've been reading the forum (all 60+pages) and it's hard to figure out what bulb folks are settling on because most of the links are obsolete...
I would give you the Amazon link from where I ordered them but it seems they are no longer available there. There was a promising one mentioned near the end of the thread but the dood who said he was going to try them seems to have gone dark* and is not responding to queries anymore.

*No pun intended, this time...

Here is a screenshot from my order history showing them. These are pretty good if only a little "floody" but still a LOT better than the anemic OEM halogens (which somehow appear BROWN against the Xenon low beam).

Screenshot_20191103-140700_Firefox.jpg

As you are aware, the important thing is the depth of the emitters. I haven't had a chance to take any measurements but I was also looking at these:

https://www.amazon.com/dp/B07DVLFRK3/

712NcNd4m3L._AC_SX679_.jpg

...and these:

https://www.amazon.com/dp/B075L5NP51/

61cuE6TWV7L._AC_SX679_.jpg
 

Roy Kjendal

Premier Member
IBR Finisher
#9
Stephen, Did you find that you had flickering or that the error light came on.....? did you have to use a captive or resistor to correct the issue?
 

Stephen!

Premier Member
IBA Member
#10
Stephen, Did you find that you had flickering or that the error light came on.....? did you have to use a captive or resistor to correct the issue?
Nope. No errors, no flickers. Truely Plug-n-Play. The hardest part for me was not realizing the fan assembly was removable. I struggled for a couple of hours and finally used a spring hook to get the clips back into place. Turns out with the fans off, it is MUCH easier to reclip the clips.... :rolleyes: